HOW TO: Upgrade to OS 4 your AKAI S900

If you want to upgrade to the new OS 4 do the following:

Download the floppy disk image from here.

Unzip it and transfer it to a blank disk as you would do with any other floppy image, following the instructions in this post.

Now put your floppy into the AKAI S900 and POWER it ON. The OS will load automatically from disk.



There are a few new features that at the moment I haven't been able to investigate. Nice to know there's still something to discover about my sampler :)

Warning: Programs saved under OS 4 ARE NOT compatible with older OS. This means that you have to load the new OS everytime you power the AKAI on before loading OS 4 programs.

The OS image has been linked from this great page: http://wiw.org/~meta/s2k.php

26 commenti:

Noise ha detto...

Your blog is great!!

Ive just bought a s900 on ebay, can i use normal 1.44 floppy disk with the s900 or do i need to buy 700kb floppy disks?

Thanks Noise.

Anonimo ha detto...

Any disk. Cover the hole first.

Anonimo ha detto...

Hey, nice blog. Just picked up an s900 and carried out the OS4 upgrade. Only thing is, after taking out the OS4 disk and restarting the s900 is back in 0S1,2. Is this meant to happen?

Cheers, Kevin

KONEY ha detto...

Hey thanx!

What do you mean with "restart"? Switch off/on I guess, so YES, it is normal to lose the new OS4 memory.

I suggest to copy the new OS4 in every floppy and use the floppy as usual to save samples and programs. It takes a small amount of diskspace but this way the OS4 is loaded everytime you off/on the machine.

Regards
KONEY

Mark ha detto...

Is this the same OS that Akai released on floppy? If so, it has a great bug you can play with. When processing a crossfade loop you press one of the buttons (I forget which one, sorry) and it basically corrupts the sample, but in an interesting way. Got some great sounds by doing this, but it is VERY much a case of trial and error. Never comes out the same twice, but something to play with anyway. I miss my S900...

KONEY ha detto...

Yes it should be the same OS. Thanx for the advice, I will investigate further and in case write an article about that... "new feature" :)

klasus lex ha detto...

Hi. I purchased an Eprom Upgrade for an S900 on ebay sometime ago indcluding 2 floppies with OS 4 on it. I never got me a S900 (bought S950 instead). So now I want so sell that. I am a little bit confused because I read that changing the eproms is unneccessary for running OS 4. So what does this EPROM upgrade do anyway, what are the new features? There are some stickers on the eproms saying "OS 1.2", if that might help

KONEY ha detto...

Don't know, OS4 comes as a file loaded from floppy, probably there's a middle version on EPROM.

At how much would you sell that upgrade anyway?

Ryan Noha ha detto...

Hi Koney! Thanks for this great Akai s-900 resource. I have a question. I am having trouble installing OS 4 on my s900 that currently has version 1.2 installed. After I successfully transfer the OS 4 onto a disk using Omniflop, I insert it into the s900 and there is an error when loading: "OOPS BAD DATA FROM DISK." I have tried several DD and HD (with the hole covered) disks, but to no avail. Have you seen this problem before? Any help would be appreciated! Thanks!

Ryan

boris fornetti ha detto...

Koney!
Little question for you...
How do you connect pc to sampler? You use a midi to midi inputs/outputs on your soundcard and sampler, or you use some game ports for connecting it?
Thank you

boriz

KONEY ha detto...

@ Ryan Noha: This sound quite strange. Just to be sure, do you load the OS by powering the unit on with the floppy inserted? That should be the way.

@ Boris: Go for MIDI. I tried with serial a few times but never had succes, MIDI works!

Matt Kaminski (the minsk) ha detto...

is it at all possible to load the OS thru midi/sysex? or is floppy the only way? i feel like its not possible but just thought id ask...thanks!

KONEY ha detto...

Good question. I don't think it's possible because I never heard of that possibility, but I may be wrong...

Matt Kaminski (the minsk) ha detto...

hmmm interesting....any ideas on how one might try it? cause how would u get to the midi screen without loading the OS? is it always able to receive midi/sysex msgs no matter what screen your in like some other gear does?? the floppy drive on my 900 is busted or something. it just like hangs at the "akai s900 version 1.2" screen while the floppy clicks but no red light.

iloveanalogue ha detto...

Best S900 Blog ever! It seems strange, though, that the S-Series was (and is) so popular, but you can't find any disks any more.

I downloaded all of yours, Koney, (grazie) but I can't find any more anywhere else, not even on ebay can I find these floppies.

Anyone know where I can find more disk images? I have Omniflop.

KONEY ha detto...

U welcome! Floppis are rare, that's why users shall share theirs! ;)

Anonimo ha detto...

Hi folks, just found this link, hope it'll help out a bit.

http://synthzone.com/midi/akai/general/

Anonimo ha detto...

Nice blog. Would be nicer if you'd mention my page, the source of your OS4 image.

http://wiw.org/~meta/s2k.php

Thanks.

KONEY ha detto...

You're right, i've done that in the post. I planned in the future to make a page with all resources and your page would go there too.

Anyway I remember you for the PHP script to read AKAI Floppy. I asked for assistance time ago but the program was discontinued. It would be nice to make it work nowadays and have a article posted about it. If you need my help I can code PHP.

Regards

Anonimo ha detto...

Thank you very much! I had 2 os4 disks, but broken. After downloading and using your image file, I can use my s900 with os4 again!

Dan Shook ha detto...

Thanks very much for providing this information - I am having the bad-data-from-disk error along with some other folks on the board. I'm wondering what kind of disk image you tell omniflop that the image file is. When I unzip it, it has no extension (.img .akai etc etc) on it, and I have to put something after it otherwise omniflop doesn't recognize it as an image. I have tried renaming it into s900os4.akai as well as s900os4.img and omniflop will go ahead with either, but then they don't work in the sampler.

Also, do you use format/write in omniflop or just write (after formatting in the s900)? If I format the disk in the sampler, omniflop won't write the image to it unless I let omniflop reformat it before writing.

Any help is most appreciated - thanks again!

KONEY ha detto...

Sorry my unit died a few years ago and I can't help you. I recall just that files were .img :)

Dan Shook ha detto...

No problem, thanks - sorry to hear about your 900 - I have a spare-parts unit here if you are interested in fixing it - let me know if there is anything you need.

Matt Hutch ha detto...

My s900 keeps crashing after playing a few minutes. Any idea where I can find replacement ram chips?

Max Legend ha detto...

Does anyone know if you can save OS4 onto a new floppy without a PC but just inside the S900?

Anonimo ha detto...

Hi, I formatted the floppy disk with the S900.
The I decompressed s900os4.tar.gz and renamed s900os4 to s900os4.AKAI so that omniflop recognize it
I used omniflop to write the AKAI image and it works.
(It works too formatting with omniflop and/or renaming the image to s900os4.img)

Rob C Trax

Cheers,